Template:X-Series/Troubleshooting

From ZaberWiki
Jump to navigation Jump to search

Troubleshooting X-Series Motion Devices

The following sections contain tips for troubleshooting common problems. If the device is unable to communicate, and it is operating erratically, a manual factory reset can be performed through the following steps. Note that this will reset most settings.

  1. Power Off the device
  2. Push and hold the knob for the first Axis (if applicable)
  3. Power On the device
  4. Continue to hold the knob in until the blue LED is lit (~5 seconds), then release.

The device has been returned to its factory defaults and can be configured as per the steps in Initial Setup.

Front Panel Indicators

Green LED On
The device is powered on and is operating normally.
Green LED Flashes Slowly
The operating conditions of the device are outside of the recommended range.
This will occur when the supply voltage is either over or under the recommended range, the internal temperature has exceeded the set limit, or the driver has been disabled. Check the following:
  • The input voltage is within the operational range of the device. This can be read from the device with the get system.voltage command.
  • The device temperature is within range. This can be read from the device with the get system.temperature command.
  • The driver is not disabled. If the driver is disabled the result of the warnings command will contain the FD flag.
Green LED Off
The device is not powered.
Check the supply connections and power adaptor for correct operation.
Red LED On or Flashing.
A critical error has occurred.
Please contact Zaber Technical Support.
Yellow LED Always Off or Flashes but No Reply.
There are communication errors.
Please see the Communication Errors section below.

Manual Control

Turning the knob either way results in no movement
The knob may have been disabled.
Check that the knob.enable (T:107) setting is correct.
Restore the default parameters through the system restore (T:36) command.
The axis won't cover the full range of travel.
The axis hasn't been homed.
Turn the knob anti-clockwise until the axis reaches the fully retracted position (closest to the motor). The axis will home and the full range of travel available.

Unexpected Behaviour

The axis doesn't respond to a move command.
The axis needs to be homed before use.
Send the home (T:1) command.
The axis is moving on its own and running against the ends of travel.
The position encoder has de-synchronized.
Reset the device by power cycling it or sending the system reset (T:0) command, then re-initialize it with the home (T:1) command.
The axis is moving very slowly. It used to move faster.
The speed settings may have been changed inadvertently.
Send a system restore (T:36) command.
The axis makes louder than normal noise during travel and is frequently slipping.
This condition happens if the thrust needed is more than the thrust available from the axis.
Check the following:
  • The force on the axis is less than the maximum thrust.
  • The voltage matches the specified voltage. Read the voltage using the get system.voltage command. Voltage less than the specified voltage for the device will reduce the positioner’s maximum thrust.
Test the following:
  • Try a slower target velocity.
  • Try a lower acceleration and deceleration.
  • Clean the screw and lightly re-grease it with a grease that does not degrade plastics.
Please contact Zaber Technical Support.
The axis doesn't cover the full range of travel, or runs into the end.
A setting might have been inadvertently changed.

Communication Errors

There is no communication with the device; the Yellow LED does not come on or flash.
There are several things that should be checked:
  • Make sure the correct serial port is selected. Try selecting other serial ports in the software.
  • Check the baud rate, hand shaking, parity, stop bit, etc. when configuring the serial communications software. The required settings are listed in the RS-232 Communications section above.
  • Make sure there are no bent pins in the ends of all the data cables
  • Make sure the device is powered. The Green LED should be on.
  • If the computer is a laptop running on batteries, try plugging in the power. Some laptops disable the serial ports when running on batteries.
  • Make sure a null modem adaptor or cable is not being used.
  • Make sure the correct adaptors(if any) are being used. Refer to the pinouts in the RS-232 Communications section above.
  • If the problem was encountered when trying to control the device with custom software, try using one of the demo programs from the Zaber website to verify that the hardware is functioning properly.
Two or more devices both respond to commands sent to device 1.
Most devices are shipped with their device number set as 1. If you connect the devices through Zaber Console, you will be prompted to renumber them. If you aren't able to install and open Zaber Console, send the renumber (T:2) command in the software you are using to set all of the device numbers to different values.
The Yellow LED comes on briefly when sending a command, but the device does not move and does not reply.
Check baud rate, hand shaking, parity, stop bit, etc. are set as per the RS-232 Communications defaults.
The device numbers may not be what is expected, issue a renumber (T:2) command. Make sure that the computer does not transmit anything else while the devices renumber.
If using the Binary Protocol, check the following:
  • 6 bytes are transmitted and that the device number and command are valid.
  • The software does not transmit any control characters such as line feed and spaces.
  • That the serial port is not configured with a termination character (it often defaults to linefeed).
If problems are encountered when using custom software, try using one of the demo programs from the Zaber website to verify that the hardware works.
The device does not behave as expected when software sends it a series of commands.
The computer might be set to Unicode. This is common for languages that use non-Latin based characters. Go to Control Panel/Regional and Language Options/Advanced. Select a language for non-unicode programs. This should be English or another Latin based character language.
Check what is being sent out of the serial port. stackoverflow.com has a list of some tools to monitor serial ports.
In Binary mode, the device does not send replies but otherwise works.
Auto-reply might have been disabled via T:101.
Send a system restore (T:36) command.
If the problem is encountered when trying to control the device with custom software:
  • Use a demo program from the Zaber website to verify that the hardware is functioning properly.
  • Make sure that the receiving part of the code or commercial package is correct.
  • Check the serial port settings are correct.
  • Check connectors for bent or broken pins.
In Binary mode, the device sometimes returns fewer than 6 bytes.
This typically indicates a problem with the serial port settings. Some serial ports are set to automatically recognize and remove specific control characters such as carriage returns when they appear in the RS-232 receive buffer.
Check that the settings are correct and are not removing or replacing characters.

Slipping and Stalling

The axis makes noise but does not move.
The axis is stalling.
Try removing all external loads. If the axis now extends and retracts normally, the problem is excessive load. Try to reduce the load and ensure the load is less than the maximum thrust. A higher thrust or torque can be achieved by lowering the speed of the axis using the maxspeed (T:42) setting.
If an axis is stalling with no external load at default speed and acceleration settings then it requires servicing.